HomeОбразованиеRelated VideosMore From: Kan Yektaoglu

Hackintosh Sierra 10.12.6 RX480/580 iGPU Fix

87 ratings | 9872 views
Hackintosh Sierra 10.12.6 RX480/580 iGPU Fix RX480/RX580 is supported OOB with the macOS Sierra 10.12.6 update but still an iGPU is required to boot up the system fully. This guide will help you to get rid off iGPU to boot your Hackintosh with Polaris based GPUs such as RX480 & RX580. After doing this fix there won't be any black screens for non iGPU users. Links: Vit9696 https://github.com/vit9696 https://github.com/vit9696?tab=repositories Aaron Hunt https://twitter.com/aaronhunt330/ Music: Kontinuum - Aware [NCS Release] Platform: i5-3470 32GB DDR3 P8-B75V XFX RX580 8GB (Also tested on RX480) macOS Sierra 10.12.6 Clover Boot Loader 4128
Html code for embedding videos on your blog
Text Comments (36)
Joe Pags (1 month ago)
I appreciate you doing this and I know it's old now.. but, I'm getting horrible graphics on my machine with a Radeon RX580. Followed the steps here but getting a never ending logo and wheel when I try to boot back into the OS. Any ideas?
Blender Dünyası (2 months ago)
Thanks mate! Now I try it but on my mobo there is no igpu. I have MSI Bazooka B350M and MSI RX 580 8GB. I also can not see the HDD to mount in Clover. It just shows USB and I will try directly copy to HDD where Mac is installed. I really need help about graphic card driver and I am so new to Hackintosh. Thank you.
Emirhan KUL (5 months ago)
Abi Bende Asus RX 470 i5 8400 Var Gözünü Seviyim Şunu Bi Full Başta Sona Türkçe Anlat.
Bhavik Singh (6 months ago)
don't you lose hardware acceleration like this?
Kalyan Kommanapalli (6 months ago)
Thank you for your help. This fixed my issues with Sapphire RX470 with mac OS Sierra. Itw as the most easiest of all the videos and forums that I went through days researching and thanks to you it all works like a charm!
mesfigas (8 months ago)
Pfffffff my motherboard doesn't have IGPU setting :( its a Asus B350 prime plus. I looked at the bios settings and such thing like IGPU doesn't exists. I m doomed.
Radu Arsenie (9 months ago)
Thank you very much for filming the whole thing. Not many people do. I was interested to see the transition between first stage and second stage boot. So it's nice to see that you actually took the time to capture the entire flow. Nice job. Also, it looks like the screen flashes white between first stage and second stage boot (like a really bright camera flash). Kind of annoying. I see there is no such issue when booting iGPU + dedicated GPU... Any fix for it?
Vladan Jankovic (10 months ago)
Can you play 4K files normally when this fix is applied? I have a problem with 4K files, if I disable iGPU, but when it is enabled I got FCP crush everytime it imports media.
Vladan Jankovic (8 months ago)
No, I'm still using older version of FCPX 10.2.3 with iGPU enabled and 4K is working normaly, but can't use FCPX 10.3.x beacuse of crushing. When I disable iGPU 10.3.x works normally, but can't work with 4K files because of loosing frames when skimming or playing from FCP and Finder also.
tuaguilareal (8 months ago)
did you solve the problem?
sha106b (11 months ago)
I wonder if I can also use that fix for the install process of Mac OS 10.12.6.
Einfach Yannic (11 months ago)
work this too with an and radeon rx 460 4gb(my graphicskard)?
ibrahim TEMEL (11 months ago)
Verdiğin dosyalar High Sierra'da malesef bir işe yaramıyor. Başka ne yapabiliriz kaan abi?
Gerson Ruiz (11 months ago)
Before everything, thank you very much for this excellent work! and this is great news for me that I am setting up a hackintosh, I only have a couple of questions this also works on AMD hackintosh? or just for hackintosh INTEL? or both?
Manuel Bernal (1 year ago)
Hi, thanks for the video, I used it a lot and it works 100% with rx470 sapphire nitro.
Alessandro Gargano (1 year ago)
I need help, I have an rx 580 8gb but its clock speed its @300Mhz. how can I boost it?(Sapphire special edition)
Hekarath (1 year ago)
Did the trick. Thanks!
Panna Acida (1 year ago)
Hi, I've a problem...I have full AMD PC (FX-6300 and RX480) I can't use your method because I can't load macOS, I have a black screen post installation of amd sierra. Any solution?
İbrahim Tarzan (1 year ago)
You are the man! :D
NoderTaco Taco (1 year ago)
i very Hope its really work beacouse i want try you can send me video to install the new version to sierra? i sorry for my english ... and its sure work to rx 480?
Kan Yektaoglu (1 year ago)
it works
CasaBlanca Cb (1 year ago)
Thanks a lot. It work on high sierra beta 5 too.
cristalloadrian (4 months ago)
mine not work, it reboot or stop segnal
Orkun Kaya (1 year ago)
Kaan bey, R9 290 kozmetik olarak gözüküyor. Fakat ekran kasmaya devam ediyor. -raddvi komutu kullanmalı mıyım? config.plist ve AMD8000. kext edit iptal mi etmeliyim?
Kan Yektaoglu (1 year ago)
config.plist de hiç bir flag kullanmanıza gerek yok efi nin içine doğru kextleri atmışsanız otomatik olarak tanıma işlemi gerçekleşecektir
Andr3z Official (1 year ago)
Friend would help me with my AmdRX460, since I can not make my graphics work
Angelo Roncalli (1 year ago)
Great video! I am looking to a better GPU for working in 4k video editing, using Premiere 2017 and After Effects 2017. I was thinking to purchase GTX 1060 SSC, but I have discovered this information about AMD gpu’s. Do you think I will have issues or difficulties using Asus Radeon RX580 OC Edition 8GB)? This GPU will do the job better than Nvidia fo my needing? Thanks for your reply.
Gaurang Joshi (1 year ago)
If you're going to use Adobe apps, then better go with Nvidia cards and Windows OS.
bbmatias22 (1 year ago)
This is only for intel
Very nice men.my hackintosh is fix after very days!!!thank you for this video My gpu :msi rx 480 gaming x 8gb Mb:asus x99 a/usb3.1 Cpu:5820k (OC 4.5) 1.387500 V Storage:2ssd and 2hdd Not use kext for gpu! Flag:-xcpm npci=0x2000 ...
Kan Yektaoglu (1 year ago)
clean your config.plist you dont need any flags
Leo Unglaub (1 year ago)
I also have a MSI RX 480 but when i boot myhackintosh after adding the two kext files the boot process stops at 50% and it is stuck there. I see the Apple logo and the status bar, but it is stuck at 50%. Any ideas?
my card RX 580
10.12 ???
Kan Yektaoglu (1 year ago)
10.12.6
ibrahim TEMEL (1 year ago)
Çok güzel bir video olmuş. Eline sağlık Kaan abi devamını bekleriz. Türkçe olsa fena olmazdı.

Would you like to comment?

Join YouTube for a free account, or sign in if you are already a member.